30 Apr 2003 steve   » (Master)

It's been a busy month but I can't let the month get away without posting at least one news update! A lot of my time lately has been sucked up helping a variety of local groups with computer issues.

Susan completed an update of the website for the Frisco Association for the Arts. It looks a bit more artsy than the old, interim site. We're just starting some work on the Arts of Collin County site but it's got a ways to go before it's ready for prime time.

I also helped set up my first foal cam recently. Barry Jordan has a couple of horses out at his ranch and wanted a webcam so everyone could watch the birth of a foal that was due this month. He's limited to a dial-up link and MS Windows so it presented a number of challenges. Barry and Eric Yundt (both fellow DPRG members) had been working on it for a while and they actually did 99% of the work but I got drafted to help out and provided a windows binary of wget that solved the last remaining roadblock to getting the image from the webcam to the windows box and then up to the server. The dial-up link limits the refresh rate of the image but it's still kinda cool.

Speaking of DPRG stuff, I've been spending a good bit of time helping get the new DPRG computer lab up to speed. Using a couple of Linksys routers I picked up on eBay, we've now got high-speed Internet access. I've got a Red Hat 7.3 box set up to act as the LAN server and it's also going to host development environments for several of the microcontrollers commonly used in the group. So far, I've built GCC cross-compilers for the Atmel AVR and Motorola 68k chips. I've also installed Pete Gray's Linux port of Small-C for New Micros' IsoPod (these are really cool little boards). More to come as I get time.

I upgraded my workstation at the office to Red Hat 9 a couple of weeks ago and was pleased with the results. It really should have been called 8.1 as it seems very much like 8.0 but without a lot of the bugs. The GUI looks great; anti-aliased fonts, professional looking icons, I can run the occasional KDE program without it looking all goofy like it did on previous versions of Gnome. Overall it looks way better than Windows XP but not as good as OS X (yet).

After a week or so of playing with 9 on my workstation, I got brave enough to upgrade one of our servers this week. The biggest problem I ran into on the server was that wu-ftpd is gone and there was no explanation of why or what replaced it. There was just no ftp service, no wu-ftp entry in the xinetd directory, and RPM -q indicated wu-ftpd wasn't installed. I eventually found that vsftpd replaced it but isn't running by default. My initial impression is that vsftpd is a piece of junk. The first problem is that it has some sort of problem running under xinetd so you have to run it as daemon. Once I got it running, I started getting complaints that it was corrupting files. A little investigation revealed that vsftpd pretends to support ASCII transfer mode but really ignores ASCII mode requests and just sends everything in binary mode resulting in corrupted text files. After a bit of poking around, I found a setting in the config file that turns off this bizarre behaviour. I suppose it was the frequent security issues with wu-ftpd that prompted Red Hat to make the switch but I'd much prefer they'd picked something else to switch to (and it would have been nice if they could mention this sort of drastic change in the documentation somewhere)...

Latest blog entries     Older blog entries

X
Share this page