Older blog entries for ericzayers (starting at number 24)

30 Sep 2005 (updated 30 Sep 2005 at 13:41 UTC) »

I've got my ATTINY26 based hbridge to work with PWM after nutsing around with it for a while. Don't ask me what the PWM rate is. I just kept changing the Timer 1 prescaler value until things work right (too fast, and the motor just makes a whining noise.) Now I'll try to get I2C communication and the encoder wheel working.

I need another chip to be the I2C master to communicate with the hbridges. I purchased a Wright Hobbies DevBoard-M32 for just USD$25. Nathaniel from AHRC brought one of the ATMEGA8 versions of this board to a meeting a few months ago and I really liked it. The board came quickly and I soldered it all up and tested it out in a little over an hour. Eddy Wright was very helpful too. It has a pinout for each pin of the ATMEGA32 and some extra pins for VCC, +5V and Ground for perephrial stuff. I highly recommend it.

Its my birthday today! Its been about a year since I did major work on my website. I did some housekeeping this morning and worked out a few kinks.

21 Sep 2005 (updated 23 Sep 2005 at 11:22 UTC) »

I haven't been doing nothing for all these moths.

- I finished my mini sumo mods and competed again. I won against my competitor from 14 February, but then I went up against delta force and lost. He just scooped me up and pushed me out of the way. I need more weight. I'm only at 350 grams. Something was going wrong with my eye sensors too.

- Built a digital thermometer out of an Atmel microprocessor and some nice freebie high intensity Green LEDs.

- I tried my HBridge again to try to control my 12V wiper motors, this time following a schematic gleaned from the Internet. I got it working for almost 30 minutes before it self destructed. No sparks, but some smoke from one of the MOSFET's

- I went and bought a current regulated power supply at Fry's the next day. That has helped a lot...

- I found that there was a followup schematic to the first one. I created a PCB for it and am now debugging it. I'll update the hbridge page on my website one of these days.

My mini sumo bot is all working now. I had my first Mini Sumo contest on 5 Feb 2005... and I lost big time. The competitor was another MarkIII kit, but when the two robots went head to head, his just pushed mine back and hardly slowed down.

I noticed he had Alkaline cells (1.5 volts) and I was using NiMH cells (1.2 volts), so I think that might have been the big difference.

I ordered the more powerful servos from Junun.org and also got the nice sticky tires. I'm going to add 2 more AA cells to my power supply too.

An issue I'm struggling with now is that I'm a little bit over on the regulation width. I've used my dremmel a bit on the servo and wheel to shave of a bit. I may have to cut off some of the fancy new tires to get them within the 10 cm width. That would be a shame - I want as much traction as possible!

I translated the C sample code for the MarkIII to be compatible with the CCS C compiler. It seems like I fiddled endlessly with getting the servo centering right. Reaming out will a bigger drill bit helped, but did not solve the problem. Then, someone tipped me off that if I shorten the potentiometer shaft on the servo it might help. That fixed the problem!

I broke down and read the CCS C Compiler manual. Now I think I can make the HEX files work with the default boot loader, but first, I want to get back to beating that inanimate block of wood before the AHRC meeting on Saturday.

Just got back to the MarkIII mini sumo kit today. I am using the CCS pic compiler and Linux, and realized I'd have to use another bootloader (Rick Farmer's) than the one that came pre-loaded. I tried to 'reload' the bootloader, but didn't pay very close attention to the instructions and replaced the bootloader with one of my test programs (whoops!). I had to break out the hardware PIC programmer and put the new bootloader on the old fashioned way.

To test the compiler, I used the MarkIII prototyping board. After some head scratching, I realized I'd soldered the headers in the board upside down. After scratching some of the traces and re-routing Vss and Vdd I have a blinking LED on my prototyping board.

After some trying, I realized that my servo mod was not quite right - the left servo wouldn't stay centered, so I had to ream out the gear with a larger drill bit. I can reliably control the servos with my own program, so now I'm cooking with gas. Next step, program it to beat an inanimate block of wood.

The MarkIII wheels didn't fit on the JR racing servo, so I had to drill out the wheels, then mount them on a round servo hub.

The MarkIII kit is all together and after reversing the wiring to the IR sensors, it all tests out properly. I used BotLoader under WINE to get it to program under Linux. A fellow AHRC member (Bob Baxter) loaned me a sumo ring and gave me a blank one to paint. What a guy!

26 Dec 2004 (updated 26 Dec 2004 at 21:56 UTC) »

For Christmas, I gave myself a Mark III mini sumo kit from Junun.org. A nice kit but probably not for the beginner.

The board is compact and looks very flexible, since all 40 pins of th PIC 16F877 are brought out to a header. Make sure you have a small soldering tip! The soldering of the board went quickly. I have yet to test it.

The servos it shipped with were unmodified, so the next step was to modify them. For me, the servo modification didn't go so well. I saw the instruction, "Be careful not to drill out the threads" but then used a large drill bit to be SURE I could get my screwdriver in there and now the screw to attach the servo horn/wheel no longer fits. The second servo I sheared off the moulded axle when trying to remove the servo stop.

Live and learn! I had two other servos lying around and even though they were slightly different (JR Racing instead of Futaba) I was able to modify them without breaking anything.

The good news is that there are 364 days left to plan for next Halloween.

I got the H Bridge working, but then my control circuit went all flaky on me and I couldn't get it working in time for trick-or-treating. We put out a blacklight shining on a black board with the message "Happy Halloween" instead.

I am now building a UV light table to use for circuit board printing.

Now the relay based HBridge is working. Now to work on the mechanical parts (a rope with a pulley to move the ghost along.)

27 Oct 2004 (updated 27 Oct 2004 at 13:32 UTC) »

I'm experimenting with building a little HBridge. I let the smoke out of some MOSFETs trying build the HBridge. It was exciting, but not the kind of excitement I like.

Someone suggested I try using a current limited power supply while testing. Sounds like a good idea. I'm switching the circuit over to using relays since I have a tight deadline (Halloween is this weekend!), I don't have a current limited power supply at the moment, and I don't really need to use PWM at the moment.

As an offshoot, I'm going to try to help a friend with a rig to help him automate some sandblasting he does if I can ever get this #!$@$@ HBridge to work!

15 older entries...

X
Share this page